
 
 
 
 
PrinterAdmin Print Job Manager 8.0 – User Guide                                                                    
If you have any questions, please send email to support@printeradmin.com or fill out the form at 
http://www.printeradmin.com/support.htm or call us.  
 
Part I Components, Requirements and Installation Instructions (Page 2 ~ 15) 
PrinterAdmin Print Job Manager 8.0 (Required) Printer Admin - Print Job Manager 8.0 can be installed 
on a single computer and you will be able to track and manage printing of all other computers. Printer 
Admin - Print Job Manager 8.0 provides centralized print manager / print tracker / print counter. Printer 
Admin - Print Job Manager 8.0 is an easy to use print management software allowing management, control, 
quota, limit, tracking, count, audit and printing restrictions in Windows / Linux / Unix and Mac OS clients. 
Printer Admin - Print Job Manager 8.0 supports all brands of printers and all types of printing environments 
(print server / non print server / direct IP printer / workstation connected printer). (Page 2 - 3) 
 
Print Job Agent 2.0 (Optional Add-on) Print Job Agent allows users to check their balance on their 
workstation, confirm or authenticate their print jobs from their workstations (Windows, Mac OSX / Classic, 
or Linux client) before they actually print, bill the print jobs by entering a client code or project code, and 
track the print jobs on the workstation-connected-printers or the printers themselves in a non-print server 
printing environment (Users send the print jobs to the printer directly via the IP address of the printer, 
instead of the shared printer on the print server). This software must be installed on the workstations that 
require the above features. (Page 4 ~ 12) 
 
Print Job Report 4.0 (Optional Add-on) Print Job Report is a tool which allows you to generate and view 
100 reports including 64 default reports and 36 customized reports, and provides the ability to export these 
reports to Adobe-PDF, MS-Word, MS-Excel and Rich Text formats. These reports are originally written in 
English, but can be easily translated into any language which takes just a few minutes. (Page 13~ 14) 
 
Remote Account Manager 1.0 (Optional Add-on) Remote Account Manager allows you to add / edit 
users / billing code / client code / project code, update account balance / quota / group / pin from any 
computer. (Page 15) 
 
Print Job Web User 1.0 (Optional Add-on) Print Job Web User will create an intranet website within 
your network that allows admin to view all print jobs, add / delete a user or update user account 
information (print quota, PIN, group, user status) through a web browser. It also allows users to view and 
export their print jobs, check their account information or change pin through a web browser. For more 
information, please see Print_Job_Web_User_Guide.pdf or http://www.printeradmin.com/print-job-
web.htm. 
 
Part II Installation Options and Examples (Page 16 ~ 29) 
Installation Options and Examples that require only PrinterAdmin Print Job Manager 8.0 
If you don’t need the features that Print Job Agent provides, you can just install PrinterAdmin Print Job 
Manager 8.0 only. 
Option 1: Install PrinterAdmin Print Job Manager 8.0 on a central computer (Page 16) 
Option 2: Install PrinterAdmin Print Job Manager 8.0 on your current print server computers (Page 17) 
 
Installation Options and Examples that require both PrinterAdmin Print Job Manager 8.0 and Print 
Job Agent 2.0 
Option 3: Install PrinterAdmin Print Job Manager 8.0 on a central computer and install Print Job Agent on 
the workstations (Page 18) 
 
Part III Preferences (Page 31 – 40) 
Part IV Step by Step Configuration and FAQ (Page 41) 
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Part I Components, Requirements and Installation Instructions 
 
PrinterAdmin Print Job Manager 8.0 (Required) 
PrinterAdmin Print Job Manager 8.0 System Requirements 

Operating System          Windows 32-bit and 64-bit 
CPU                                300 Mh or higher  
Memory                          256 MB or more  
Hard Disk Free Space     80 MB 

 
In order to install PrinterAdmin Print Job Manager 8.0, you must have the administrator rights on the 
installation computer. You also need the administrator rights on all monitored printers in order to be able to 
control the print jobs.  
 

 
 
1. Double-click setup.exe and follow the on-screen instructions. 
 
2. After the installation completes, double-click the shortcut “PrinterAdmin Print Job Manager 8.0” on your 
desktop or    select "Start -> Programs -> PrinterAdmin Software -> PrinterAdmin Print Job Manager 8.0" 
to run the program.  
 
3. You can make PrinterAdmin Print Job Manager run as a windows service regardless of whether someone 
is logged    on by clicking the menu item “Tools ->Install Windows Service”, then go to Control Panel-
>Administrative Tools-->Services-->PrinterAdmin Print Job Manager, change the Local System Account 
to your account that is currently logged into this computer and with which you installed the PrinterAdmin 
Print Job Manager software. If you install PrinterAdmin Print Job Manager on Windows Cluster server, 
Please configure PrinterAdmin Print Job Manager in the group as a "generic service". 
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Uninstall PrinterAdmin Print Job Manager 8.0  
 
1. If PrinterAdmin Print Job Manager service is installed, click the menu item “Tools -> Uninstall 
Windows Service.” 
 
2. Open Add/Remove Programs, select PrinterAdmin Print Job Manager, and click on the Remove button, 
then restart     the computer. 
 
3. Remove the installation folder. (E.g. C:\Program Files\PrinterAdmin Software\PrinterAdmin Print Job 
Manager) 
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Print Job Agent 2.0 for Windows, Mac OS X/Classic and Linux x86 (Optional Add-on) 
 
Print Job Agent must be installed on those workstations (Windows, Mac, or Linux client) that: 
 
1. Print jobs which must be confirmed or authenticated before they actually print 
2. Print jobs which must be billed to clients or projects by entering client code or project code before they 

actually print 
3. Print jobs which must be tracked and logged for workstation-connected printers or the printers in a 

non-print server printing environment (Users send the print jobs to the printer directly via the IP 
address of the printer, instead of the shared printer on the print server). 

4. Users must be able to check their balance on their workstations. 
 
Print Job Agent 2.0 for Windows 
 
Print Job Agent System Requirements 

Operating System          Windows 32-bit and 64-bit 
CPU                                300 Mh or higher  
Memory                          256 MB or more  
Hard Disk Free Space     25 MB 

 
Note: For testing purpose, you can install Print Job Agent on the same computer that has PrinterAdmin 
Print Job Manager installed, so it is easy for you to make testing. In production environment, please remove 
Print Job Agent from the computer where PrinterAdmin Print Job Manager is installed. 
 
Note: Before you run Print Job Agent, please make sure PrinterAdmin Print Job Manager 8.0 is running on 
a central computer or print server and the option “Enable agent communication” is checked in the menu 
item “Print Jobs -> Preferences -> Advanced.”  
 
Note: You must have administrator rights on the workstations in order to install Print Job Agent. 
 
Local Installation 
 

 
 
1,  Double click Print Job Agent.msi, then follow the on-screen instructions.  
 
2. After the installation completes, you have option to launch Print Job Agent. It can also be launched from 
"Start  Programs  Print Job Agent  Print Job Agent".  
 
Note: Print Job Agent is run automatically every time when user logins. It stops running when user logouts. 
 
Note: If you don’t want to create shortcut in "Start  Programs", you can use Orca utility to remove the 
shortcut from Print Job Agent.msi. See the step 1 in the following silent installation. 
 
3. Enter the IP Address of the PrinterAdmin Print Job Manager computer.  
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Note: This information is required when you run Print Job Agent on the workstations the first time. (Print 
Job Agent.msi can be modified to include the computer name or IP Address of your PrinterAdmin 
Print Job Manager by using Orca utility, so you don’t have to enter it manually when Print Job 
Agent is started the first time. Please check the following Silent installation step 1).  

 
Silent Installation 
 
1. Modify Print Job Agent.msi to include the computer name or IP address of the computer where you 
installed PrinterAdmin Print Job Manager 8.0, so you don’t have to enter it manually when you run Print 
Job Agent the first time on each workstation. 

 
    We recommend using ORCA utility (part of the Windows Installer SDK) to do this. 
     1.1 Download the orca.msi from http://www.printeradmin.com/download/orca.msi  . 
     1.2 Double click it to install Orca.   
     1.3 Run Orca,  
           click the menu File -> Open to open Print Job Agent_Silent_Install.msi,   
           click menu Edit -> Find, enter SERVER_IP,  
           click the value of SERVER_IP, 
           type the name or IP address of the computer where PrinterAdmin Print Job Manager 8.0 is installed. 
     1.4 Click the menu File->Save, then exit Orca. 
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If you don’t want to create shortcut in Windows "Start  Programs”, you can remove all shortcuts in   
“Shortcut” table. 
 

 
 
2.  Go to MS-DOS prompt, type msiexec /i “Print Job Agent.msi” /qn 

 
 
Note: You must run the command line as Administrator on Windows Vista or later. To do this, Click Start, 
click All Programs, and then click Accessories, Right-click Command prompt, and then click Run as 
administrator. 
You can also use Windows group policy or third party installation software to remotely install CZ Print Job 
Agent on all workstations at one time. For remote silent installations, please visit 
http://www.printeradmin.com/remoteinstall.htm . 
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3. CZ Print Job Agent runs automatically every time when user logins. It stops running when user logouts. 
 
Uninstall Print Job Agent 2.0 
Open Add/Remove Programs, select Print Job Agent 2.0, then click on the Remove button. 
 
Print Job Agent can also be uninstalled silently.  
Go to MS-DOS prompt, type msiexec /x “Print Job Agent.msi” /qn 

 
 
Note: You must run the command line as Administrator on Windows Vista or later. To do this, Click Start, 
click All Programs, and then click Accessories, Right-click Command prompt, and then click Run as 
administrator. 
 
You can also use Windows group policy or third party installation software to remotely uninstall CZ Print 
Job Agent from all workstations at one time. 
 
Print Job Agent Known Issue 
 
 The popup doesn't appear when user prints. How to fix it? 
 Print Job Agent doesn’t track the the direct IP printer or workstation connected printer via USB 
 cable. How to fix it?? 
 
Solution 1: 
 
If the popup on all client computers doesn't work, the local firewall settings  may block PrinterAdmin Print 
Job Manager to send the message to the agent. On the computer that has PrinterAdmin Print Job Manager 
installed, add "printczm.exe" (e.g. C:\Program Files\PrinterAdmin Software\PrinterAdmin Print Job 
Manager\printczm.exe) to the exception list of local firewall settings (Control Panel -> Windows Firewall). 
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Solution 2: 
 
The Windows firewall settings (Start --> Control Panel --> Windows Firewall) on client computer may 
block agent to connect to server (PrinterAdmin Print Job Manager). When agent is installed and run first 
time, it will be added to the exceptions automatically. If not, please add "pagent.exe" (e.g. C:\Program 
Files\Print Job Agent\Print Job Agent\pagent.exe) to exception list of local firewall settings (Control Panel 
-> Windows Firewall). You can also use group policy to add pagent.exe to the exceptions of Firewall 
settings on multiple computers at one time at http://www.printeradmin.com/agentexception.htm . 
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Solution 3: 

If the print job agent installed on the client computer doesn't show active in PrinterAdmin Print Job 
Manager Preferences --> Advanced --> Check Agent Status, go to client computer, find and run 
C:\Program Files\Print Job Agent\Print Job Agent\serverip.exe. If the IP address of PrinterAdmin Print Job 
Manager server is not correct, please enter the correct one and click OK button, then check PrinterAdmin 
Print Job Manager Preferences --> Advanced --> Check Agent Status again. 

 

Solution 4: 

 9



The antivirus software firewall settings may block agent to connect to server (PrinterAdmin Print Job 
Manager). Please add "pagent.exe" (e.g. C:\Program Files\Print Job Agent\Print Job Agent\pagent.exe) to 
exception list of antivirus firewall settings or add exception for TCP port 14128. 

Solution 5: 

Please check the number of users in Preferences -> Users / Groups and the number of printers in 
Preferences --> Printers -> List of Monitored Printers, then check how many users and printers your license 
includes in menu Help -> Registration -> Enter / Upgrade License Code. For example your license is for 
"50 Users & 5 Printers". If the number of users in Preferences -> Users / Groups is already 50, then the 
print job for 51th user will not be tracked and the popup will not show. Please remove some users in 
Preferences -> Users / Groups (and restart the PrinterAdmin Print Job Manager service if it is installed), 
then test it again. 

Solution 6: 

If popup still doesn't appear after you try above solutions and iPrint Job Agent is installed on Windows,  
uncheck "Internet Protocol Version (TCP/IPv6)".  

 
 
Solution 7: 
 
If popup doesn't appear on all client computers, click PrinterAdmin Print Job Manager menu item "Print 
Jobs --> Backup / Reset Database" to backup and reset the database. If you can't see the menu item "Print 
Jobs --> Backup / Reset Database", exit PrinterAdmin Print Job Manager, rename the file C:\Program 
Files\PrinterAdmin Software\PrinterAdmin Print Job Manager\config\setdb to a different name, then start 
PrinterAdmin Print Job Manager again. 
 
Uninstall Print Job Agent 2.0 
Open Add/Remove Programs, and select Print Job Agent, and click on the Remove button. 
Note:You can also use Windows group policy or third party installation software to remotely uninstall Print 
Job Agent from the workstations. 
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Print Job Agent 2.0 for Mac OS X / Classic and Linux x86 
Mac or Linux workstations must print to the shared printer on windows print server in order for the Agent 
to work: 
 
LPR printing 
1. Start the “Print Services for Unix” on your Windows Print server. If you can’t find this service, please  

add it from add /remove programs -> add / remove windows components -> Other Network Files and 
Print Services -> Print Services for Unix. 

2. On the Mac, add a LPR printer 
3. Enter the windows print server name in Printer Address and the name of the shared printer in Queue  
    Name 
 

Or you can click “+” button in Printers and Fax folder, then click  “Windows” button to browse the  
shared printer on the Windows Print Server. 

 
 
Or SMB printing 
Edit  / etc » cups » printers.conf file 
<DefaultPrinter printer> 
  ..... 
  Location yourdomain 
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  DeviceURI smb://yourdomain_username:password@yourdomain/printserver/printer_share_name 
  State Idle 
  Accepting Yes 

….. 
</Printer> 
 
To get the best result, please do the following: 
1. Install PrinterAdmin Print Job Manager on your current Windows print server. 
2. In Control Panel--> Printers, right click the shared printer, open the properities of the printer --> 
Advanced, uncheck "Enable advanced printing". 
3. Turn off spool file sharing for the shared printer. Please see http://www.printeradmin.com/printer-
control-faq.htm#20  for details. 
4. Rename c:\program files\PrinterAdmin Software\PrinterAdmin Print Job Manager\config\sparse0 to 
sparse. 
5. Delete or rename file C:\Program Files\PrinterAdmin Software\PrinterAdmin Print Job Manager 
\config\linmac. 
 

 
 
Mac OS X/Classic: PrintJobAgent.app.tar 
1. Copy Addon_Print Job Agent\Mac_OSX_or_Classic\ PrintJobAgent.app.tar to Mac computer. 
2. Double click PrintJobAgent to run it. If it doesn’t run, try a different agent. The host name of the Mac 

must be in the format of computerName.local (for example: m123.local where m123 is the computer 
name of the Mac). If not, the popup may not work. The HOSTNAME can be defined in 
/etc/hostconfig. Restarting the daemon, or rebooting, will result in the hostname command working as 
expected. 

3.     You can make agent run automatically when Mac machine starts up: 
Option 1: 
Step 1: Find the PrintJobAgent application icon and click on it. 
Step 2: Click on the File menu and select Make Alias. Drag the alias to the desktop where you can get at it. 
Step 3: Double-click to open the System Folder and locate the Startup Items folder. 
Step 4: Drop the alias into the Startup Items folder. The next time you start up your Mac, the application 
will launch. 
 
Option 2: 
Go into the system preferences - accounts - login items, you can adjust what programs load and don't load 
at sign in. 
 
Linux x86: PrintJobAgent 
1. Copy folder PrintJobAgent to Linux computer. 
2. In terminal mode, run ./PrintJobAgent  
 
If popup on Mac client or Linux client doesn’t appear when you print, please check if Mac client or Linux 
client prints to shared printer on the Windows print server. 
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Print Job Report 4.0 (Optional Add-on) 
 
Print Job Report is a tool which allows you to generate and view 100 reports including 64 default reports 
and 36 customized reports, and provides the ability to export these reports to Adobe-PDF, MS-Word, MS-
Excel and Rich Text formats. These reports are designed for your print cost analysis and client billing, and 
are originally written in English, but can be easily translated into any language which takes just a few 
minutes. 
 
Print Job Report 4.0 System Requirements 

Operating System          Windows 32-bit and 64-bit 
CPU                                300 Mh or higher  
Memory                          128 MB or more  
Hard Disk Free Space     6 MB 

 

If Print Job Report and PrinterAdmin Print Job Manager are installed on the same computer, the database 
file “printSaver.mdb” is located in the installation folder of PrinterAdmin Print Job Manager. 
(e.g. C:\Program Files\PrinterAdmin Software\PrinterAdmin Print Job Manager). If you install Print Job 
Report and PrinterAdmin Print Job Manager on different computers, you can share the database folder from 
the computer where PrinterAdmin Print Job Manager is installed, Print Job Report can connect to the 
shared database remotely (on the second computer) to generate reports. (e.g. \\PrinterAdmin Print Job 
Manager Computer Name\Shared Database Folder\printSaver.mdb.

 
 
1. Double click "PrintJobReport.exe" or "PrintJobReport1.exe" to install Print Job Report. 
PrintJobReport.exe is based on NET Framework 2.0 or later. PrintJobReport1.exe is based on NET 
Framework 1.1. You can use either one to install Print Job Report 4.0. 
 
2. Follow the on-screen instructions. 
 
3. After the installation completes, double-click the shortcut “Print Job Report” on your desktop or    select 
"Start -> Programs -> Print Job Report -> Print Job Report" to run the program. 
 
4. Select the included sample databases to test how it works. The sample database named    
“printSaver_Sample.mdb” is located in the installation folder of Print Job Report. (E.g. C:\Program     
Files\Reporting Tool\Print Job Report). The real database file “printSaver.mdb” is located in the    
installation folder of PrinterAdmin Print Job Manager (e.g.  C:\Program Files\PrinterAdmin 
Software\PrinterAdmin Print Job Manager). 
 
Uninstall Print Job Report 4.0 
 
1. Open Add/Remove Programs. 
 
2. Select Print Job Report. 
3. Click on the Remove button. 
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Print Job Report Known Issue 
 
I get the database logon prompt when I  generate reports. How can I fix it? 
 

 
 
Option 1: 
 
1. Click "Select Database" to select the sample database "printSaver_Sample.mdb" that is located in the 
installation folder of Print Job Report  e.g. C:\Program Files\Reporting Tool\Print Job Report. 
 
2. Click "Generate Report" and select a report from the dropdown list. If the report is generated correctly, 
then select the real database e.g. the database file in the installation folder of PrinterAdmin Print Job 
Manager. 
 
Option 2: 
 
If you have MS-Access 2007 installed on your computer, you can use it to open the database file e.g. 
C:\Program Files\PrinterAdmin Software\PrinterAdmin Print Job Manager\printsaver.mdb, then in Print 
Job Report, click "Select Database" and "Generate Report" to see if you can see the report. 
 
Option 3: 
 
1, Install Print Job Report on a different computer 
 
2, Share the database folder from the computer where PrinterAdmin Print Job Manager is installed (e.g. 
C:\Program Files\PrinterAdmin Software\PrinterAdmin Print Job Manager). 
 
3. Map the network share folder from the computer where Print Job Report is installed (e.g. \\PrinterAdmin 
Print Job Manager Computer Name\Shared Database Folder). 
 
4, Click "Select Database" in Print Job Report and connect to the shared database (e.g. \\PrinterAdmin Print 
Job Manager Computer Name\Shared Database Folder\printSaver.mdb). 
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Remote Account Manager 1.0 (Optional Add-on) 
 
Remote Account Manager allows you to add / edit users / billing code / client code / project code, update 
account balance / quota / group / pin from any computer. 
 
Remote Account Manager 1.0 System Requirements 

Operating System          Windows 32-bit and 64-bit 
CPU                                300 Mh or higher  
Memory                          128 MB or more  
Hard Disk Free Space     1M 

 
Before you run Remote Account Manager, please make sure PrinterAdmin Print Job Manager 8.0 is 
running on a central computer or print server and the option “Enable agent communication” is checked in 
the menu item “Print Jobs -> Preferences -> Advanced.” You must also have administrator rights on the 
computer where you install Remote Account Manager. 
 

 
 
1. Go to Remote Account Manager folder and double-click “Remote Account Manager.msi”. 
 
2. Follow the on-screen instructions.  
 
3. After the installation completes, double-click the shortcut “Remote Account Manager” on your    desktop 
or select "Start -> Programs -> Remote Account Manager -> Remote Account Manager " to run the    
program. 
 
4. Enter the name or IP address of the PrinterAdmin Print Job Manager computer.  
 
Note: This information is required when you run Remote Account Manager on the workstations the first 
time and it will be saved in the file server_ip.ini located in the installation folder of Remote Account 
Manager. 

 
5. Click the button “Verify Remote Account Manager Password”. The password is defined in “Preferences     
-> Print Jobs” of PrinterAdmin Print Job Manager. 

 
 
Uninstall Remote Account Manager 1.0 
 
1. Open Add/Remove Programs. 
 
2. Select Remote Account Manager. 
 
3. Click on the Remove button. 
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Part II Installation Options and Examples  
For latest version, please visit http://www.printeradmin.com/quick-start.htm  
 
PrinterAdmin Print Job Manager 8.0 can track and control printing for the following types of printers: 
1. The shared printers on the print-server computers 
2. The printers connected to the network directly via the IP address without using a print server 
3. The printers connected to the workstations locally 
4. The printers connected to the print-server device e.g. HP JetDirect 

 

 
 
Installation Options and Examples that require only PrinterAdmin Print Job Manager 8.0  
 
If you don’t need print job confirmation / authentication / billing by client code / print job tracking for 
workstation-connected- printer / print job tracking for a non-print-server printing environment that Print 
Job Agent provides, you can install only PrinterAdmin Print Job Manager 8.0 to track and control the print 
jobs. 
 
Option 1: Install PrinterAdmin Print Job Manager 8.0 on a central computer 
 
1, Install PrinterAdmin Print Job Manager 8.0 on a central computer by following the instructions in Part I 
(Page 2). 
 
2, If you already have print servers on your network, you can simply add the shared printers onto those    
print servers (e.g. \\print_server\printer_shared_name) to the computer where PrinterAdmin Print Job 
Manager is installed. To add the network printers to the PrinterAdmin Print Job Manager computer, you 
can follow the "Add Printer Wizard" and select "Network Printer".  
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3, After the printers have been added, you can then click refresh button and add these network printers from    
the list of available local / network printers to the list of monitored printers in the menu item “Print Jobs -> 
Preferences-->Printers” of PrinterAdmin Print Job Manager 8.0. 
 

     
 
Option 2: Install PrinterAdmin Print Job Manager 8.0 on your current print server computers 
 
If you install PrinterAdmin Print Job Manager on a print server computer, it can track not only the printers 
on the local print server, but also the printers on the other print servers.  
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Installation Options and Examples that require both PrinterAdmin Print Job Manager 8.0 and Print 
Job Agent 2.0 
 
Option 3: Install PrinterAdmin Print Job Manager on a Central Computer or a Print Server computer and 
install Print Job Agent on the workstations as needed for the following five scenarios 
 
Note: PrinterAdmin Print Job Manager 8.0 must be installed and run before Print Job Agent is installed and 
run on the workstations. 
 
1, Install PrinterAdmin Print Job Manager 8.0 on a central computer or a Print Server computer by 
following the instructions in Part I (Page 2). 
 
2, If you already have print servers on your network, you can simply add the shared printers on those    
print servers (e.g. \\print_server\printer_shared_name) to the computer where PrinterAdmin Print Job 
Manager is    installed. To add the network printers to the PrinterAdmin Print Job Manager computer, you 
can follow the "Add    Printer Wizard" and select "Network Printer".  
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3, After the printers have been added, you can then click refresh button and add these network printers from    
the list of available local / network printers to the list of monitored printers in the menu item “Print Jobs  --
>Preferences-->Printers” of PrinterAdmin Print Job Manager 8.0.  
 

 
The above printer settings are applied to Scenario 1, 2, 3 and 4. 
 
Scenario 1: You want to enter project code or client code before the print jobs actually print in order to bill 
back your clients. In this scenario, Print Job Agent needs to be installed on the workstations (Windows, 
Mac OSX / Classic, or Linux client computer) that require the entering of a code before the print jobs will 
print.  
 
S1.1 Select the following options in the menu item “Print Jobs->Preferences->Advanced”.  
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S1.2 Click “Billing Code” to add the new client billing codes. 
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S1.3 Install Print Job Agent on the workstations (Windows, Mac OSX / Classic, or Linux client        
computer) by following the installation instructions in Part I (Page 5). After installation, click “Start->        
Programs->Startup->Print Job Agent” to start the agent.  
 
S1.4 Enter IP or host name of the central computer where PrinterAdmin Print Job Manager 8.0 is installed.  
 
Note: This information is required when you run Print Job Agent on the workstations the first time and it 
will be saved in the file server_ip.ini located in the installation folder of Print Job Agent and value data of 
string SERVER_IP in the registry key: My Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Print Job 
Agent. The installation file Print Job Agent.msi can be modify to include the name/IP of your 
PrinterAdmin Print Job Manager computer, so you don’t have to enter it manually when Print Job 
Agent is started the first time on each workstation. Please refer to the Silent installation in Part I 
(Page 7). 
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S1.5 When a user sends a print job from a workstation, the print job is paused by PrinterAdmin Print Job 
Manager  (The option “Pause the print job on the print server is checked in PrinterAdmin Print Job 
Manager Preferences -> Advanced) and a popup window appears on that workstation for the user to select 
the Billing Code in the dropdown list.  When the “Print” button is clicked, the print job is printed out.  
 

 
 
Scenario 2: You want users to be able to confirm or cancel the print jobs before the print jobs can be 
printed. In this scenario, Print Job Agent needs to be installed on the workstations (Windows, Mac OSX / 
Classic, or Linux client computer) that require print job confirmation.  
 
S2.1 Select the following options in the menu item “Print Jobs->Preferences->Advanced”of PrinterAdmin 
Print Job Manager on the central computer. 
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S2.2 Refer to S1.3. (Page 21) 
 
S2.3 Refer to S1.4. (Page 21) 
 
S2.4 When a user sends a print job from a workstation, a popup window appears on that workstation. 
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The print job is paused by PrinterAdmin Print Job Manager (The option “Pause the print job on the print 
server is checked in PrinterAdmin Print Job Manager Preferences -> Advanced). When the user clicks the 
“Print” button, the print job is printed out.  
 
Scenario 3: You require users to enter pin before the print jobs can be printed. In this scenario, Print Job 
Agent needs to be installed on the workstations (Windows, Mac OSX / Classic, or Linux client computer) 
that require print job authentication.  
 
S3.1 Select the following options in the menu item “Print Jobs->Preferences->Advanced”of PrinterAdmin 
Print Job Manager. 
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S3.2 Refer to S1.3. 21) 
 
S3.3 Refer to S1.4. (Page 21) 
 
S3.4 When a user sends a print job from a workstation, a popup window appears on that workstation. 
          

 25



 
 
The print job is paused by PrinterAdmin Print Job Manager (The option “Pause the print job on the print 
server is checked in PrinterAdmin Print Job Manager Preferences -> Advanced). When the user clicks the 
“Print” button, the print job is printed out.  
 
Scenario 4: You require users to enter user name and pin before the print jobs can be printed. In this 
scenario, Print Job Agent needs to be installed on the workstations (Windows, Mac OSX / Classic, or Linux 
client computer) that require print job authentication.  
 
S3.1 Select the following options in the menu item “Print Jobs->Preferences->Advanced”of PrinterAdmin 
Print Job Manager. This scenario also apply when all users use the same windows login account, and you 
want to  be able to identify who prints, you must select “Another User” and create accounts for each user in        
“Print Jobs->Preferences->Users/Groups”. 
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S3.2 Refer to S1.3. (Page 21) 
 
S3.3 Refer to S1.4. (Page 21) 
 
S3.4 When a user sends a print job from a workstation, a popup window appears on that workstation. 
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The print job is paused by PrinterAdmin Print Job Manager (The option “Pause the print job on the print 
server is checked in PrinterAdmin Print Job Manager Preferences -> Advanced). When the user clicks the 
“Print” button, the print job is printed out.  
 
Scenario 5: You don’t have print servers on your network, and all workstations print to the printers directly 
via the IP address of the printers or print to the workstation connected printer via LPT, USB cable. You 
want to track and log the print jobs sent to these printers. In this scenario, Print Job Agent needs to be 
installed on all workstations (Windows computer).  For more information, please refer to the Agent 
installation in Part I (Page 5). 
 
S4.1 Select the following options in the menu item “Print Jobs->Preferences->Advanced”of PrinterAdmin 
Print Job Manager. 
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S4.2 Refer to S1.3 (Page 21). 
 
S4.3 Refer to S1.4 (Page 21). 
 
S4.4 When a user sends a print job from a workstation that has Print Job Agent installed, the printers is         
added to the list of monitored printers automatically in the menu item “Print Jobs -> Preferences ->         
Printers” of PrinterAdmin Print Job Manager 8.0 if the printer is not already in the list.  
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Part III Preferences 
• Preferences --> Printers 

 

 
 
Define Cost / Page 
The Cost / Page includes the base cost, discount for duplex printing (printing on both sides of the paper) 
and extra costs for color printing. 
Example: 
Base cost: $0.10   Duplex Discount / page: 20%  Color cost / page: 50% 
The total cost for 10 pages with duplex and color printing: 10   * (0.10 - 0.10 * 20% + 0.10 * 50%) = $1.30 
The total cost for 10 pages with color printing: 10  * (0.10 + 0.10 * 50%) = $1.50 
 
Paper Size Charging 
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Example: 
Base cost: $0.10   Duplex Discount / page: 20%  Color cost / page: 50% 
The total cost for 10 pages with duplex and color printing on A3 297 x 420 mm: 
10  * (0.10 - 0.10 * 20% + 0.10 * 50% + 0.10 * 20%) = $1.50 
The total cost for 10 pages with color printing on C size sheets:  
10  * (0.10 + 0.10 * 50% + 0.10 * 30%) = $1.80 
 
Undefined Paper Sizes 
 

 
 

If "Undefined #" is shown on the PrinterAdmin Print Job Manager main screen --> Printed Jobs,  then you 
can click the menu item "print jobs --> Preferences-->paper size charging-->undefined paper sizes" to 
defined the "undefined #"  

Maximum pages per print job 
The print job which exceeds the limit will be deleted automatically. 
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Available Printers 
The available printers include all printers on the PrinterAdmin Print Job Manager computer. They can be 
network printers (\\print server\shared printer name) and local printers with LPT, TCP/IP or LPR ports. 
Multiple printers can be selected by holding down the 'Ctrl' key to select printers to be added to the list of 
monitored printers. 
 
Refresh Printer List 
Refresh the list of available printers. After you add / remove a printer to / from the PrinterAdmin Print Job 
Manager computer, you can click the refresh button to refresh the list. 
 
Monitored Printers 
Multiple printers can be selected by holding down the “Ctrl” key to removed them from the list of 
monitored printers. 
 
Update Cost 
1, Define the new value of the base cost per page, duplex, color or limit per print job. 
2, Select one or multiple printers from the list of monitored printers and click update button. 

• Preferences --> Print Jobs 

 
 
Show Printed Jobs 
Show Printed Jobs by the user id, computer name and printer name.  
 
Auto Delete the first waiting Job on each printer 
If the first print job in the printer queue is held too long, it may be a print job that is stuck and might cause 
other print jobs to be held in the queue. 
 
Update Database for Reports 
Finalize the records in the database so you can use the free tool Print Job Report to generate and view 100 
different reports. Updating the Database for Reports can be done according to the scheduling. 
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Report Translation 
Translate 100 reports to other languages. 
 
Backup and Optimize Database 
We recommend backing up and optimizing the database when its size exceeds 100MB (about 300,000 - 
400,000 print job records) to improve the performance of PrinterAdmin Print Job Manager 8.0. 
 
The database is copied to the “backup” folder (e.g. C:\Program Files\PrinterAdmin Software\PrinterAdmin 
Print Job Manager\backup) and is named as the current date. (e.g. 020105.mdb), then the database is reset 
to be empty for the best performance of PrinterAdmin Print Job Manager. This operation can be run 
automatically by setting the database size or schedule. If you want to merge multiple databases into one, 
you can click the menu item Print Jobs --> Merge Database. 
 
Running on Citrix / Windows terminal server 
If PrinterAdmin Print Job Manager is installed on a Citrix / Windows terminal server, this option must be 
checked. 
 

• Preferences --> Users / Groups 

 
Users Status 
You can prevent the print job from printing that is submitted by a disabled user account in "Policies." You 
can also set the user account age in "Policies." 
 
Set PIN 
To authenticate the print job before it actually prints, a pin needs to be set for the users and the add-on Print 
Job Agent must be installed on the user's workstation. 
 
Import 
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The users / groups can be imported from the Windows Active Directory. The users / pin can be imported 
from a CSV file (samples: http://www.printeradmin.com/download/ImportFiles.zip). The new users can be 
added to the database automatically when they send a print job. 
 
Export 
Export the list to a file in Excel, HTML and Text format. 
 
Add user 
You don't have to add the users manually.  The users can be added to the database automatically when they 
send a print job. 
 
Edit Group 
The default group is called "Print Users." You can add a new group (department) and assign users to it, 
then you are able to monitor the printing based on the group (department). 
 

• Preferences --> Policies 

 
 
Balance 
Set the initial balance for the new users when they print. This also enables balance tracking for all 
users. For example, if you set the initial balance to $20.00, and a new user submits a print job with a cost of 
$5.00, then the new user will be added to the list of "Users/Groups" automatically and the new user's 
balance will be $15.00. 
 
If you disable balance tracking, all users will have an "unlimited" balance.  
 
The balance can be reset manually or by a schedule in three ways: 
 
1: Reset balance to: All users' balances are reset to the value you define. 
2, Increase balance by: All users' balance is increased by the value you defined. 
3, Reset + balance to And add -  balance to: For example, if A user has a positive balance of $2.00 and B 
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    user has a negative balance of -$3.00, and you set the value to $20.00, then after this operation, A user 
    has a new balance of $20.00 and B user has a new balance of $18.00. 
4, Reset balance based on groups: click "Edit Group" in "Preferences --> users/Groups" and define the 
    balance to be reset. 
 
User Restrictions 
The user accounts are listed in "Users/Groups." The status of a user account can be updated manually by 
clicking the "Edit User" button in "Users/Groups." 
 
Document Restrictions 
Define the specific strings or specific file types in the document title of a print job that will not be printed. 
For example, if you define the string "gif",  then a print job with the string "picture.gif" in the title will be 
paused or deleted automatically. If you define the string "document*.doc", then the print job with the string 
"document1.doc" or "document2.doc' will be paused or deleted automatically. 
 
More Policies 
 

 
 
 

• Preferences --> Advanced 
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Enable Agent Communication  
Please refer to the above Installation Option 1 & 2 
A add-on Print Job Agent needs to be installed on the workstations as needed. 
 
Hide Agent Icon 
If this option is checked, then the Print Job Agent icon will not show on the system tray when it is started. 
 
Allow Exit 
If this option is checked, then users can exit Print Job Agent by right-clicking the icon on the system tray 
and selecting exit. 
 
Popup Confirmation Window 
The popup confirmation window can be used for print job confirmation, print job authentication and 
client/project billing. You can configure the following four fields: Billing Code, User, and User PIN 
depending on your requirements. After configuration, you can click "Test Popup Window" to see the popup 
window that will also be shown on the workstations with Print Job Agent installed. 
 
Example 1: Users are required to confirm the print job before it actually prints. 
 
In the menu item “Print Jobs-->Preferences-->Advanced", only the option "Popup confirmation on the 
workstation when a print job is submitted" needs to be checked. 
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Example 2: Users are required to enter the pin before the print job actually prints. 
 
In the menu item “Print Jobs-->Preferences-->Advanced", the option "Enable Print Job Authentication or 
Charge to a different account" and option "Require PIN" need to be checked. 
 

 

 
Example 3: Users are required to select or enter Billing Code (client code or project code) to be charged 
before the print job actually prints. 
 
In the menu item “Print Jobs-->Preferences-->Advanced", the option "Enable Print Job Authentication or 
Charge To a different account" needs to be checked and "Shared Account # / Project #" needs to be 
selected. You can also click the "Billing Code" button to add the new shared account # or project #. 
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Example 4: Users are required to enter user name and user PIN. 
 
In the menu item “Print Jobs-->Preferences-->Advanced", the option "Enable Print Job Authentication or 
Charge to a different account", “Another user” and "Require PIN" need to be checked. 

 

 
Excluded Printers 
If the user sends a print job to the printer in the list of excluded printers, then the popup windows will not 
show on the users' workstation. 
 
Popup Timeout 
Define the time in minutes the popup will show on the workstations. If the popup window times out, then 
the print job will be cancelled automatically. 
 
Billing Code (Client Code or Project Code) 
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Check Agent Status 
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Part IV Step by Step Configuration and FAQ  
 
Step by Step Configuration 
 
http://www.printeradmin.com/quick-start.htm 
 
http://www.printeradmin.com/userguide/QuickStart.zip 
 
FAQ 
 
http://www.printeradmin.com/printer-control-faq.htm 
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